Back to overview
Degraded

Web/API Connectivity

Oct 01 at 08:28am BST
Affected services
OpenCorporates Website entity search
OpenCorporates API

Resolved
Oct 01 at 08:45am BST

We're happy to announce that all services are functioning normally again.
Thank you for your understanding.

Created
Oct 01 at 08:28am BST

We're currently experiencing a technical issue that's affecting our services.
Our team is investigating the cause and working on a resolution as quickly as possible.